枝log

とりあえず始めてみたものの・・・

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

debianEtchでXfce4.4

WinXP上のVMwarePlayerで動かしているdebianEtchのデスクトップ環境をXfceにしようと思いたつ。

せっかくなので4.4を入れようと考えて、APTのリポジトリにcdnのtestingを追加してsynapticを起動したのだが、なぜかパッケージ情報の更新に失敗してlennyのパッケージが導入できない。
一応cdn以外のリポジトリも試してみたのだが、ことごとく失敗。testingが含まれてなければ問題ないんだが、それではxfce4.4はインストールできない。

エラーメッセージでググってみても解決策はみつからない。

E: Dynamic MMap ran out of room
E: wportuguese を処理中にエラーが発生しました (NewVersion1)
E: Problem with MergeList /var/lib/apt/lists/cdn.debian.or.jp_debian_dists_etch_main_binary-i386_Packages
E: パッケージリストまたは状態ファイルをパースまたは開くことができませんでした


一行目は主にaptlineに追加しすぎると出るらしいのでcdnのstableとtestingのみにしてみたが、それでも変化無し。aptのCache容量を増やしてみても結果は

E: Dynamic MMap ran out of room
E: wportuguese を処理中にエラーが発生しました (NewVersion1)
E: Problem with MergeList /var/lib/apt/lists/cdn.debian.or.jp_debian_dists_etch_main_binary-i386_Packages
E: パッケージリストまたは状態ファイルをパースまたは開くことができませんでした
E: list ディレクトリをロックすることが出来ません

となってsynapticにパッケージは表示されない

しかたがないのであきらめてstableのxfce(4.3.99.2)を導入。


と、ここまでやってstableとtestingの混在がよろしくないという記述を見つけたのでそれにしたがってみるとエラーは相変わらず出るものの、synapticにはきちんとtestingのパッケージ群が表示されている。

うーん... 4.4.2.1に上げてみるべきか否か...すっきりしないなあ。
スポンサーサイト

コメント

コメントの投稿


管理者にだけ表示を許可する

トラックバック

トラックバックURLはこちら
http://ed1a.blog35.fc2.com/tb.php/10-e53a3791
この記事にトラックバックする(FC2ブログユーザー)

FC2Ad

上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。