枝log

とりあえず始めてみたものの・・・

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

EeePC1000HAでDebianlenny 4

せっかくなんでデュアルブートにしてあるDebianでも無線LANを使えるように
してみる。

こんどは「接続が不安定」と言う表記を見かけたのでUbuntuでは試さなかった
madwifiを試してみる。

リポジトリにhttp://eeepc.debian.net/debian lenny main contrib non-freeを追加
してあるせいか、madwifi-modulesが既にsynapticに表示されるのでそのまま
インストールしてみた。madwifi-toolsと共に。
普通はmadwifi-sourceからビルドしなくてはいけないはず。

普通に使える。

SSIDの入力やパスワードはnetworkmanagerのアイコンでできた・・・はず。
スポンサーサイト

EeePC1000HAでUbuntu8.10 3.3

無事に(?)振り出しに戻ったので、今度はndiswrapperを使ってwin用の無線
LANドライバを流用してみる。

懲りずにここを参照。書いてあるのは基本的に端末使ってコマンド打つやり
方です。俺はGUIでやりましたが、コマンドのほうが速いかも。

まずASUSのサイトからwinXP用のドライバをダウンロード。解凍しておく。

synapticでndiswrapper-common ndiswrapper-utils-1.9をインストール。

Ubuntuのメニューからシステム→システム管理→Windows Wireless Driversで
nidiswrapperを起動。

Install New Drivers→Locationでinfファイルの場所を聞かれるので、解凍してお
いたXP用ドライバファイルの中のnet5211.infを指定。
installをクリックしてnet5211が表示されたら閉じる。

端末で
$ sudo ndiswrapper -ma && sudo ndiswrapper -mi

で使えるようになる。

普通に使えるようになりました。

あの苦労はなんだったんだ・・・

EeePC1000HAでUbuntu8.10 3.2

引き続き修復法を考え中。

起動プロセスのどこかがおかしいんだとは思うが、細かいプロセス
については無知なので、問題の切り分けができない。

起動プロセスだけを修復できないものか・・・

USBUbuntuで起動して、なんとなくHDDUbuntuのパーティションを
眺めていて、ちょっと見にくかったのでnautilus(ファイルマネージャ)
の表示をアイコン表示から詳細表示に変えてみる。

と、ふと目に留まったのが更新日時の欄。起動しなくなった日に行った
作業は前述の作業のみ。その後もファイルをいじったのはlinux-backp
ort~のアンインストールのみ。

更新日時が起動しなくなった日以降のファイルのどれかが原因なわけ
だから、それを探し出せばどこがおかしくなったのか分かるかもしれん。

と探してみると、まずあやしいのが

/initrd.img

これ自体は/boot/initrd.img-2.6.27-7-genericへのリンクらしい。

他のファイルを見てみても、幸いなことに更新日時が該当するのは
/etc/modprobe.d/blacklistとapt関係のみ(たぶん)だったので、
どうやらこれが原因っぽい。

というわけで、USBUbuntuの/boot/initrd.img-2.6.27-7-generic
確認してみると

USBUbuntu /boot/initrd.img-2.6.27-7-generic サイズ8.1MB
HDDUbuntu /boot/initrd.img-2.6.27-7-generic サイズ1.9MB

全然サイズが違う・・・。

一応HDDUbuntuのinitrd.img-2.6.27-7-genericをinitrd.img-2.6.27
-7-generic.bakにリネームしてバックアップした後、USBUbuntuの
initrd.img-2.6.27-7-genericをHDDUbuntuの/boot/にコピーして
再起動。


普通に起動。

あっけなく修復できたのでいくらか拍子抜けしつつも、本当に元に戻った
のかちょっと疑いながらいろいろ試してみる。

普通に使える。


ほっとしてシャットダウンした後にふと気がついた。

結局無線LAN使えてねぇ。

EeePC1000HAでUbuntu8.10   3.1

とりあえず無線LAN云々はおいといて、Ubuntu自体の回復を試みる。

エラーメッセージで検索するも、出てきたのはUbuntu中国フォーラム
の投稿1件のみ。解決したのかすらわからん。

linux-backports-modules-intrepid-generic,kernelpanic,ubuntu,eee
等のワードを色々組み合わせて検索するも、それらしい記述は無し。

ここまでで2日費やしてます。
いよいよ再インストールしか・・・  と考え始め、どうせなら駄目もとで
色々やってみることにする。

起動不可になる前に行った操作はパッケージのインストールとmodprobeコマンド
、あとは/etc/modprobe.d/blacklistへの記述のみ。
modprobeがイマイチ分かってないが、システム全体を大きく変更するような操作
ではないはず。たぶん起動プロセスのどこかがおかしいだけで、そこを修復すれば
元にもどる気がする。  ということで

まずlinux-backport~をアンインストールしてみようと考える。
Ubuntuのインストールに使ったUSBメモリがそのままだったので、それで
bootし、ライブUSB版のUbuntuを立ち上げる。

このままでapt使っても変更はライブ版Ubuntuに行われるわけで、意味はない。
ので、とりあえずHDDのUbuntuパーティションをマウントする。
その後端末上でHDDUbuntuの/ディレクトリに移動し、一時的に/ディレクトリを
変更するchrootコマンドを使う。


$ cd /media/disk/           ←HDDUbuntuの/に移動
$ sudo chroot                 ←HDDUbuntuの/をこのプロセスの/にする

$ sudo synaptic
はさすがにエラーで動かない。
じゃあCUIで。
$ sudo apt-get --purge remove linux-backports-modules-intrepid-generic
$ sudo apt-get autoremove        ←不要になったパッケージを削除
$ exit                                      ←chrootを抜ける
$ exit

で、一応/etc/modprobe.d/blacklistに記述したblacklist  ath5も削除しておいて
再起動してみる。

エラーメッセージこそ変わったものの、起動はせず。
busyboxは使えるようになったみたいなんで、一応起動したことになるのか?
まぁだからってbusyboxは知らないので何もできないことに変わりはない。

chrootしてHDDUbuntuの/に入れば基本的にはHDDUbuntu内のファイルしか使えない
はずなので、アンインストール自体はうまくいってると思うが、やはり起動関係をいじらな
いと無理か・・・。

EeePC1000HAでUbuntu8.10  3 無線LAN

無線LANは普通にインストールしただけでは使えませんでした。

まぁ使わないので全く気にしていなかった、と言うか使おうとして
初めて気がついたんですが。

eeeUbuntuやEasyPeasy(旧ubuntu eee)だったら使えるんでしょうけど、
今更インストールしなおす気にもなれませんし、実はeeeUbuntu
一度インストールしてみたんですが、個人的にイマイチだったので。

いろいろ調べると、

EeePC1000HAの無線LANはAtheros社のAR5007EGらしい。
1000H-Xや901とは違って、900系や4G-Xと同じみたい。

で、無線LANを使うには
① madwifi(Atheros社が公開しているlinux用ドライバ)
② array.orgのeeepc用kernelを入れる
③ ath5 ドライバ(Ubuntuのbackport使用)
④ win用ドライバを流用(ndiswrapper)

のどれからしい。

とりあえずaptが使える③をやってみることにする。

ここを参考にsynapticでlinux-backports-modules-intrepid-generic
をインストール。linux-backports-modules-2.6.27-7-genericも自動
的にインストールされる。

その後

sudo modprobe ath5k

として、さらに/etc/modprobe.d/blacklistにblacklist ath_pciと追記する。

これで使えるようになるわけではないので、システム→設定のNetwork
ConfugirationでSSIDやらを設定しておいて、再起動。



・・

・・・・・・・・

起動しないっ!

/init: line 168: maybe_break: not found
/init: line 175: run_scripts: not found
/init: line 177: maybe_break: not found
/init: line 178: log_begin_msg: not found
~中略
[   2.550148] kernel panic - syncing : Attempted to kill init!


などと表示されて、その後一切動きません。
しかたなく電源長押しで強制終了したものの、意味が分からん。

起動しなくなるような操作とは思わなかったんで軽く混乱しつつ、とりあえず
データの避難を試みる。


glubまでは正常なのでデュアルブートのdebianlennyを立ち上げて、
Ubuntuパーティションをroot権限でマウントし、重要なデータ等をdebianに
避難させる。

さて、原因究明&回復できるだろうか?下手すりゃ再インストール・・・


高確率で後者になりそうな気がしつつ、一縷の望みをかけてgoogleへ

KNOPPIX6.0.1日本語版

起動が明らかに早くなった。
compizが初期状態ではやや重い以外は軽くていい感じ。

しかし何より驚いたのはメニューの少なさ。
KDEでなくなったとはいえ使えるソフト少なすぎではなかろうか?

PartitionEditorすらない。Sambaもない。
これはもうレスキュー用途には使うなってことでしょうか?
KNOPPIXメニューすらないし。


俺が見つけきれてないだけで、設定いじったら出てくるんだろうか?
いやそれもどうなんだ。
synapticで追加しろってことなんだろうか?
スタンドアロンで使えないじゃん。

・・・・・・

KNOPPIX6.0日本語版

いつの間にか公開されてました。

まだダウンロード中なので試せてませんが、まず驚いたのがサイズ。
なんと600MB。knoppixで600にするのはだいぶ削ったんではなかろうか。

サイトの記述によるとブート処理も変更されたみたいで、かなり起動が早くなった模様。
統合デスクトップ環境をKDEからLXDEに。かなり軽いらしいんでこれも楽しみです。

LXDEは統合デスクトップ環境ではないという記述を見つけたので訂正。

既存のソフト(ウインドウマネージャ含む)を利用できるから。
ということなんだが、それでも標準のファイルマネージャやウインドウマネージャ
があるんなら同じことじゃないんだろうか?

gnomeやkdeだって変更はできるわけだし。

まあ統合デスクトップ環境をどう定義するかによるんでしょうけども。

FC2Ad

上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。